Архив

Публикации с меткой ‘Cisco’

Выясняем, к какому порту коммутатора Cisco подключено устройство с определенным IP-адресом

15 июля 2011

Итак, перед нами встала задача определенным образом настроить интерфейс коммутатора, к которому подключено устройство с конкретным IP-адресом, но номер интерфейса нам неизвестен. Нам необходимо его выяснить. Примем за исходные условия, что речь идет о коммутаторе Cisco Catalyst 2960, а к нужному нам интерфейсу подключено устройство с IP-адресом 10.100.10.92.

1. Выполним ping нужного нам IP-адреса, чтобы обновить ARP-таблицу на коммутаторе:

#ping 10.100.10.92
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.100.10.92,
timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5),
round-trip min/avg/max = 1/4/9 ms

2. Выясним MAC-адрес устройства с нужным нам IP-адресом с помощью команды show ip arp:
#sh ip arp | i 10.100.10.92
Internet 10.100.10.92 0 b8ac.6f1a.122e ARPA Vlan1

3. Мы обнаружили, что в ARP-таблице коммутатора есть запись об устройстве с IP 10.100.10.92, и что оно имеет MAC-адрес B8AC6F1A122E. Осталось выяснить, к какому интерфейсу коммутатора оно подключено. Для этого выполним поиск по таблице MAC-адресов с помощью команды show mac address-table:
#sh mac address-table | i b8ac.6f1a.122e
1 b8ac.6f1a.122e DYNAMIC Gi0/10

Нам удалось выяснить, что наше устройство подключено к интерфейсу GigabitEthernet0/10. Вуаля!

Default

Сброс Cisco IP Phone (Hard Reset)

14 июля 2011

Эпизодически сталкиваюсь с проблемами эксплуатации IP-телефонов Cisco, которые можно решить только hard-reset‘ом аппаратов. Процедура проста до безобразия:

1. Отключите питание телефона (кабель блока питания или ethernet, если у вас PoE)
2. Зажав клавишу #, включите питание обратно.
3. Подождите, пока замигают кнопки или световая индикация на трубке, и отпустите кнопку #.
4. Введите код сброса телефона до заводских настроек: 123456789*0#
5. Сброс выполнен. Телефон перезагрузится, свяжется с TFTP, обновит прошивку и заново пройдет процедуру регистрации на CUCM. Вуаля.

Default , ,

Сброс настроек сетевого интерфейса на Cisco

Чтобы сбросить параметры сетевого интерфейса на маршрутизаторе или коммутаторе Cisco, выполните в конфигурационном режиме следующую команду (к примеру, сбросим интерфейс GigbitEthernet0/7):
R01-P01-CORE-WS2960G(config)#default int g0/7

Выполнение команды вернет сообщение:
Interface GigabitEthernet0/7 set to default configuration

Default , ,

Сброс пароля на маршрутизаторе Cisco (на примере Cisco 2911V/K9)

13 мая 2011

Итак, это случилось. Вы позабыли пароль к маршрутизатору Cisco, а шпаргалку, естественно, потеряли. Что ж, ситуация вполне житейская, с каждым может случиться. Не стоит отчаиваться, механизм сброса пароля, безусловно, предусмотрен.

1. Аксиома: у вас таки должен быть физический доступ к устройству, и вы таки должны располагать компьютером с COM-портом и консольным кабелем. Если хотя бы одно из условий не выполняется, то сбросить пароль вам не удастся. На многочисленные вопросы «а можно сбросить пароль удаленно?» ответ — НЕТ.

2. Подключите маршрутизатор к компьютеру через консольный кабель и запустите терминальный клиент.

3. Перезагрузите маршрутизатор и нажмите комбинацию клавиш прерывания загрузки (шпаргалку см. тут: http://fedoseyev.ru/2011/03/standard-break-key-sequence-combinations-during-password-recovery/. Я использую эмулятор терминала Tera Term Pro Web, из таблицы по ссылке следует, что комбинация клавиш прерывания загрузки для моего Tera Term — Alt+B). Появится строка приглашения ROMMON:

4. Выполните смену конфигурационного регистра с помощью команды confreg 0x2142, после чего сбросьте устройство командой reset

Перезапуск маршрутизатора с конфигурационным регистром 0х2142 приведет к тому, что он загрузится в конфигурации по умолчанию, т.е. с заводскими настройками. Строка приглашения CLI будет выглядеть так:

5. Перейдите в привилегированный режим командой enable и скопируйте загрузочный конфигурационный файл в файл текущей конфигурации командой copy startup-config running-config

Сразу по завершении операции копирования, устройство установит в качестве действующей загрузочную конфигурацию. Для наглядности перед сбросом пароля я задал своему маршрутизатору имя yourname, которое сразу после копирования файла конфигурации появилось в CLI.

6. Теперь поменяйте пароль. Для этого войдите в режим конфигурирования терминала командой conf t и установите новый пароль командой enable secret НОВЫЙ-ПАРОЛЬ

7. Скопируйте новую конфигурацию (отличающуюся от старой только паролем) в startup-config с помощью команды copy running-config startup-config

8. Поменяйте конфигурационный регистр на вариант по умолчанию, чтобы роутер загружался с конфигурацией startup-config. Для этого войдите в режим конфигурирования терминала командой conf t и и выполните команду config-register 0x2102



Для проверки выполните команду sh ver

В конце возвращенного CLI сообщения должна быть надпись, что при перезагрузке будет использован конфигурационный регистр 0x2102.

9. Теперь выполняйте reload и наслаждайтесь возвращенным доступом к маршрутизатору.

Вуаля!

Default

Как симулировать комбинацию Break Key для входа в ROM Monitor маршрутизатора Cisco, если терминальный клиент не поддерживает стандартную

20 марта 2011

Иногда срабатывает такой способ:

1. Подключитесь к устройству со следующими параметрами:
— Скорость: 1200 бит/сек
— Биты данных (Data bits): 8 бит
— Паритет (Parity): без паритета
— Стоповые биты (Stop bits): 1
— Управление потоком (Flow Control): нет

Естественно, вывод на экран перестанет работать. Это нормально.

2. Перезагрузите устройство по питанию. Когда оно включится, нажмите пробел и удерживайте его в течении 10-15 секунд. Это и есть эмуляция комбинации Break Key.

3. Отключитесь от терминальной сессии и запустите ее снова, уже со стандартными параметрами.

Если вы все сделали правильно, то, скорее всего, вы увидете строку приглашения ROM Monitor.

Default ,

Комбинации клавиш для входа в режим ROM Monitor при загрузке маршрутизаторов Cisco

20 марта 2011

Она же — Standard Break Key Sequence Combinations During Password Recovery.

Табличка-полезняшка. Будет использована как вспомогательный материал в будущей серии публикаций.

Default ,

Настройка Cisco Catalyst 3550/3750 для подключения IP-телефонов Cisco

Для подключения IP-телефонов Cisco, настройки коммутаторов Cisco Catalyst 3550/3750 несколько отличаются от 2960. Например, использование dot1Q включается вручную, а spanning-tree аналогично выключается.

Приведу пример стандартной конфигурации интерфейса (за исходные данные примем, что data-vlan — это vlan 1, голосовой vlan — vlan 4):

Switch(config)#interface F0/1
Switch(config-if)#switchport trunk encapsulation dot1q
Switch(config-if)#switchport trunk native vlan 1
Switch(config-if)#switchport access vlan 1
Switch(config-if)#switchport mode trunk
Switch(config-if)#switchport voice vlan 4
Switch(config-if)#spanning-tree portfast
Switch(config-if)#exit

Default , , , ,

Настройка COM-порта для подключения оборудования Cisco

— Скорость: 9600 бит/сек
— Биты данных (Data bits): 8 бит
— Паритет (Parity): без паритета
— Стоповые биты (Stop bits): 1
— Управление потоком (Flow Control): нет

Default ,

Настройка DHCP-сервера на маршрутизаторе Cisco

31 января 2011

В большинстве маршрутизаторов Cisco существует возможность настроить DHCP-сервер на базе IOS. Его функциональность достаточно широка для того, чтобы, например, запустить IP-телефонию на базе CUCME в небольшом филиале.

К делу. У нас есть маршрутизатор Cisco 2951 (voice-bundle с CUCME). Исходные данные таковы:
— сеть 192.168.1/24
— зарезервированы адреса в диапазоне 192.168.1.1 — 192.168.1.20
— шлюз по умолчанию — 192.168.1.1
— CUCME-сервер — 192.168.1.1
— DNS-серверы: 192.168.1.10, 192.168.1.20

Про CUCME я упоминаю только для того, чтобы оправдать необходимость демонстрации настройки дополнительных опций DHCP. Т.к. IP-телефонам Cisco для работы необходимо указывать адрес TFTP-сервера, мы создадим в DHCP параметр (150), раздающий клиентам адрес TFTP.

Router(config)#ip dhcp excluded-address 192.168.1.1 192.168.1.20
Router(config)#ip dhcp pool Pool-Name
Router(dhcp-config)#network 192.168.1.0 255.255.255.0
Router(dhcp-config)#option 150 ip 192.168.1.1
Router(dhcp-config)#default-router 192.168.1.1
Router(dhcp-config)#dns-server 192.168.1.10 192.168.1.20
Router(dhcp-config)#exit

Default , , , ,

Регистрация сервисного контракта Cisco SmartNet

27 марта 2010

Даже специалисты службы технической поддержки Cisco признают, что по сайту Cisco нужно писать отдельный мануал. Я возьму на себя задачку попроще: напишу, как привязать сервисный контракт SmartNet к своей учетной записи на сайте Cisco. Такая привязка даст вам возможность получить доступ к определенным ресурсам сайта, для обычных пользователей недоступным.

Итак, начнем. Заходим на http://cisco.com, логинимся под своим аккаунтом и входим в его настройки, нажав “Account” в правом верхнем углу страницы:

01

Далее следуем в Profile Manager:

02

В меню сверху выбираем “Additional Access”:

03

Сообщаем, что у нас есть желание добавить номер сервисного контракта в профиль, нажатием следующей ссылки:

04

Ну и, наконец, вводим номер сервисного контракта в соответствующее поле и жмем “Submit”:

05

После этого вы автоматически попадете в Profile Manager, в котором появится такое уведомление:

06

Обычно сервисный контракт добавляется к вашему профилю в течении 2-3 часов. После того, как это случится, в Profile Manager появится следующее:

07

Теперь вы – полноценный Service Contract Owner.

Default , ,